]> git.pld-linux.org Git - packages/perl-JSON.git/blob - perl-JSON.spec
- new
[packages/perl-JSON.git] / perl-JSON.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    JSON
7 Summary:        JSON - parse and convert to JSON (JavaScript Object Notation).
8 #Summary(pl.UTF-8):     
9 Name:           perl-JSON
10 Version:        1.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MA/MAKAMAKA/JSON-1.07.tar.gz
16 # Source0-md5:  c7b385e35f37b4c8595c4f6e7eeb573e
17 URL:            http://search.cpan.org/dist/JSON/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(HTTP::Request)
22 BuildRequires:  perl(HTTP::Response)
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module converts between JSON (JavaScript Object Notation) and Perl
29 data structure into each other.
30
31 For JSON, See to http://www.crockford.com/JSON/.
32
33 # %description -l pl.UTF-8
34 # TODO
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/*.pm
59 %{perl_vendorlib}/Apache/*.pm
60 %{perl_vendorlib}/JSON/
61 %{perl_vendorlib}/JSONRPC/
62 %{_mandir}/man3/*
This page took 0.066185 seconds and 3 git commands to generate.