]> git.pld-linux.org Git - packages/perl-JSON.git/blob - perl-JSON.spec
153865a92cbdbd22fd6c9b831436ef9dae7d53d1
[packages/perl-JSON.git] / perl-JSON.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    JSON
7 Summary:        JSON - parse and convert to JSON (JavaScript Object Notation)
8 Summary(pl.UTF-8):      JSON - analiza i konwersja do notacji JSON (JavaScript Object Notation)
9 Name:           perl-JSON
10 Version:        2.16
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/JSON/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  a86d9ded2bbe67d6721ab9dcb02af138
17 URL:            http://search.cpan.org/dist/JSON/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Suggests:       perl-JSON-XS
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module converts between JSON (JavaScript Object Notation) and
26 Perl data structure into each other.
27
28 For JSON, See to <http://www.crockford.com/JSON/>.
29
30 %description -l pl.UTF-8
31 Ten moduł dokonuje konwersji między notacją JSON (JavaScript Object
32 Notation) a perlowymi strukturami danych.
33
34 Więcej informacji na temat notacji JSON można znaleźć pod adresem
35 <http://www.crockford.com/JSON/>.
36
37 %prep
38 %setup -q -n %{pdir}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/*.pm
60 %{perl_vendorlib}/JSON
61 %{_mandir}/man3/*
This page took 0.042692 seconds and 2 git commands to generate.