]> git.pld-linux.org Git - packages/perl-Inline.git/blob - perl-Inline.spec
- formatting
[packages/perl-Inline.git] / perl-Inline.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         pdir    Inline
3 Summary:        Inline perl module
4 Summary(pl):    Modu³ perla Inline
5 Name:           perl-Inline
6 Version:        0.44
7 Release:        2
8 Epoch:          1
9 # same as perl (but C-Cookbook is Artistic-only)
10 License:        GPL v1+ (except C-Cookbook) or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
13 # Source0-md5:  840f47d9b6cef39e68370faf9dceab2c
14 BuildRequires:  perl-devel >= 1:5.8.0
15 BuildRequires:  perl-Digest-MD5 >= 2.09
16 BuildRequires:  perl-Parse-RecDescent >= 1.78
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # false requires found by rpm
22 %define         _noautoreq      'perl(of)'
23
24 %description
25 Inline.pm - Write Perl subroutines in other programming languages.
26
27 %description -l pl
28 Modu³ Inline.pm - pozwala tworzyæ procedury Perla w innych jêzykach
29 programowania.
30
31 %package C
32 Summary:        Inline::C perl module
33 Summary(pl):    Modu³ perla Inline::C
34 Group:          Development/Languages/Perl
35 License:        Artistic
36 Requires:       %{name} = %{epoch}:%{version}
37 Requires:       gcc
38
39 %description C
40 Inline::C - Write Perl subroutines in C.
41
42 %description C -l pl
43 Modu³ Inline::C - pozwalaj±cy pisaæ funkcje Perla w C.
44
45 %prep
46 %setup -q -n %{pdir}-%{version}
47
48 %build
49 echo "y" | perl Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/Inline.pm
66 %{perl_vendorlib}/Inline/denter.pm
67 %{perl_vendorlib}/Inline/Foo.pm
68 %{perl_vendorlib}/Inline/MakeMaker.pm
69 %{perl_vendorlib}/auto/Inline
70 %{_mandir}/man3/Inline.3pm*
71 %{_mandir}/man3/Inline-*.3pm*
72
73 %files C
74 %defattr(644,root,root,755)
75 %doc C/Changes C/README
76 %{perl_vendorlib}/Inline/C.pm
77 %{perl_vendorlib}/Inline/C
78 %{_mandir}/man3/Inline::C*.3pm*
This page took 0.060244 seconds and 3 git commands to generate.