]> git.pld-linux.org Git - packages/perl-Inline.git/blob - perl-Inline.spec
- up to 0.50
[packages/perl-Inline.git] / perl-Inline.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         pdir    Inline
3 Summary:        Inline Perl module - write Perl subroutines in other programming languages
4 Summary(pl.UTF-8):      Moduł Perla Inline - tworzenie funkcji perlowych w innych językach programowania
5 Name:           perl-Inline
6 Version:        0.50
7 Release:        1
8 Epoch:          1
9 # same as perl (but C-Cookbook is Artistic-only)
10 License:        GPL v1+ (except C-Cookbook) or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/Inline/%{pdir}-%{version}.tar.gz
13 # Source0-md5:  cb9377b494819924bddf2de20c90f3ab
14 URL:            http://search.cpan.org/dist/Inline/
15 BuildRequires:  perl-devel >= 1:5.8.0
16 BuildRequires:  perl-Digest-MD5 >= 2.09
17 BuildRequires:  perl-Parse-RecDescent >= 1.78
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # false requires found by rpm
23 %define         _noautoreq      'perl(of)'
24
25 %description
26 The Inline module allows you to put source code from other programming
27 languages directly "inline" in a Perl script or module. The code is
28 automatically compiled as needed, and then loaded for immediate access
29 from Perl.
30
31 %description -l pl.UTF-8
32 Moduł Inline pozwala umieszczać kod źródłowy w innych językach
33 programowania bezpośrednio wewnątrz skryptu lub modułu perlowego. Kod
34 jest w razie potrzeby automatycznie kompilowany, a następnie ładowany
35 w celu bezpośredniego dostępu z poziomu Perla.
36
37 %package C
38 Summary:        Inline::C Perl module - write Perl subroutines in C
39 Summary(pl.UTF-8):      Moduł Perla Inline::C - tworzenie funkcji Perla w C
40 Group:          Development/Languages/Perl
41 License:        Artistic
42 Requires:       %{name} = %{epoch}:%{version}
43 Requires:       gcc
44
45 %description C
46 Inline::C is a module that allows you to write Perl subroutines in C.
47
48 %description C -l pl.UTF-8
49 Inline::C to moduł pozwalający pisać funkcje Perla w C.
50
51 %prep
52 %setup -q -n %{pdir}-%{version}
53
54 %build
55 echo "y" | perl Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod \
66         $RPM_BUILD_ROOT%{perl_vendorlib}/Inline/*.pod
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %{perl_vendorlib}/Inline.pm
75 %{perl_vendorlib}/Inline/denter.pm
76 %{perl_vendorlib}/Inline/Foo.pm
77 %{perl_vendorlib}/Inline/MakeMaker.pm
78 %{perl_vendorlib}/auto/Inline
79 %{_mandir}/man3/Inline.3pm*
80 %{_mandir}/man3/Inline-*.3pm*
81
82 %files C
83 %defattr(644,root,root,755)
84 %doc C/Changes C/README
85 %{perl_vendorlib}/Inline/C.pm
86 %{perl_vendorlib}/Inline/C
87 %{_mandir}/man3/Inline::C*.3pm*
This page took 0.028427 seconds and 3 git commands to generate.