]> git.pld-linux.org Git - packages/perl-Importer.git/blob - perl-Importer.spec
1dcc2e8c6b5f251cbcaf31c175f5143698b2d184
[packages/perl-Importer.git] / perl-Importer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Importer
6 Summary:        Importer - Alternative but compatible interface to modules that export symbols
7 Summary(pl.UTF-8):      Importer - alternatywny, ale kompatybilny interfejs do modułów eksportujących symbole
8 Name:           perl-Importer
9 Version:        0.025
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/E/EX/EXODIST/Importer-%{version}.tar.gz
15 # Source0-md5:  09660fe32701e28ee149258315de0262
16 URL:            https://metacpan.org/release/Importer
17 BuildRequires:  perl-devel >= 1:5.8.1
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.98
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module acts as a layer between Exporter and modules which consume
27 exports. It is feature-compatible with Exporter, plus some much needed
28 extras. You can use this to import symbols from any exporter that
29 follows Exporters specification. The exporter modules themselves do
30 not need to use or inherit from the Exporter module, they just need to
31 set @EXPORT and/or other variables.
32
33 %description -l pl.UTF-8
34 Ten moduł działa jako warstwa między Exporterem a modułami
35 pobierającymi wyeksportowane symbole. Jest zgodny co do możliwości z
36 Exporterem, zawiera też trochę dodatków. Można go użyć do importowania
37 symboli od dowolnego eksportera zgodnego ze specyfikacją Exportera.
38 Moduły eksportujące nie muszą wykorzystywać ani dziedziczyć z modułu
39 Exporter, muszą tylko ustawić @EXPORT i/lub inne zmienne.
40
41 %prep
42 %setup -q -n %{pdir}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README.md
63 %{perl_vendorlib}/Importer.pm
64 %{_mandir}/man3/Importer.3pm*
This page took 0.048424 seconds and 2 git commands to generate.