]> git.pld-linux.org Git - SPECS.git/blob - perl-IP-Country-DB_File.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / perl-IP-Country-DB_File.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # unit tests
4 #
5 %define         pdir    IP
6 %define         pnam    Country-DB_File
7 Summary:        IP::Country::DB_File - IPv4 and IPv6 to country translation using DB_File
8 Name:           perl-IP-Country-DB_File
9 Version:        3.03
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IP/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  749ea4ca65126ef38d30bb386865c49e
16 URL:            https://metacpan.org/dist/IP-Country-DB_File
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl-Math-Int64
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 IP::Country::DB_File is a light-weight module for fast IP address to
28 country translation based on DB_File. The country code database is
29 stored in a Berkeley DB file. You have to build the database using
30 build_ipcc.pl or IP::Country::DB_File::Builder before you can lookup
31 country codes.
32
33 This module tries to be API compatible with the other IP::Country
34 modules. The installation of IP::Country is not required.
35
36 There are many other modules for locating IP addresses. Neil Bowers
37 posted an excellent review. Some features that make this module
38 unique:
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %attr(755,root,root) %{_bindir}/build_ipcc.pl
63 %{perl_vendorlib}/IP/Country/*.pm
64 %{perl_vendorlib}/IP/Country/DB_File
65 %{_mandir}/man1/build_ipcc.pl.1*
66 %{_mandir}/man3/IP::Country::DB_File*.3*
This page took 0.20697 seconds and 3 git commands to generate.