]> git.pld-linux.org Git - SPECS.git/blob - perl-IO-Socket-IP.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / perl-IO-Socket-IP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - needs network connection
4 #
5 %define         pdir    IO
6 %define         pnam    Socket-IP
7 Summary:        IO::Socket::IP - Family-neutral IP socket supporting both IPv4 and IPv6
8 Name:           perl-IO-Socket-IP
9 Version:        0.39
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  fe49e4f6638c55124b4f1fb9ee8fe134
16 URL:            http://search.cpan.org/dist/IO-Socket-IP/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides a protocol-independent way to use IPv4 and IPv6
24 sockets, intended as a replacement for IO::Socket::INET. Most
25 constructor arguments and methods are provided in a
26 backward-compatible way.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make}
35
36 %{?with_tests:%{__make} test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc Changes README
50 %{perl_vendorlib}/IO/Socket/IP.pm
51 %{_mandir}/man3/IO::Socket::IP*.3pm*
This page took 0.616646 seconds and 3 git commands to generate.