]> git.pld-linux.org Git - packages/perl-IO-Multiplex.git/blob - perl-IO-Multiplex.spec
- it's *not* on GPL
[packages/perl-IO-Multiplex.git] / perl-IO-Multiplex.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    IO
7 %define pnam    Multiplex
8 Summary:        IO::Multiplex - Manage IO on many file handles
9 #Summary(pl):   
10 Name:           perl-IO-Multiplex
11 Version:        1.03
12 Release:        2
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  rpm-perlprov >= 3.0.3-16
17 BuildRequires:  perl >= 5.6
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 IO::Multiplex is designed to take the effort out of managing multiple
23 file handles.  It is essentially a really fancy front end to the select
24 system call.  In addition to maintaining the select loop, it buffers all
25 input and output to/from the file handles.  It can also accept incoming
26 connections on one or more listen sockets.
27
28 # %description -l pl
29 # TODO
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 perl Makefile.PL
36 %{__make}
37
38 %{!?_without_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README TODO
51 %{perl_sitelib}/IO/Multiplex.pm
52 %{_mandir}/man3/*
This page took 0.039041 seconds and 4 git commands to generate.