]> git.pld-linux.org Git - SPECS.git/blob - perl-HTML-Tree.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / perl-HTML-Tree.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    HTML
6 %define         pnam    Tree
7 Summary:        A suite for making parse trees out of HTML source
8 Summary(pl.UTF-8):      Pakiet do tworzenie przetworzonych drzew źródła w HTML-u
9 Name:           perl-HTML-Tree
10 Version:        5.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7d22aa8fda76a60a88ce47bc63f4d21d
17 URL:            http://search.cpan.org/dist/HTML-Tree/
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-Module-Build >= 0.2808
21 %if %{with tests}
22 BuildRequires:  perl-HTML-Parser >= 3.46
23 BuildRequires:  perl-HTML-Tagset >= 3.02
24 BuildRequires:  perl-Test-Fatal
25 %endif
26 # HTML::FormatText used in HTML::Element by default; don't use as BuildRequires (loop)
27 Requires:       perl-HTML-Format
28 Requires:       perl-HTML-Parser >= 3.46
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is a collection of modules that represent, create and extract
34 information from HTML syntax trees. Modules included: HTML::Element,
35 HTML::TreeBuilder, HTML::AsSubs, HTML::Parse.
36
37 %description -l pl.UTF-8
38 Kolekcja modułów do operowania na drzewach składni HTML. Pakiet
39 zawiera moduły: HTML::Element, HTML::TreeBuilder, HTML::AsSubs,
40 HTML::Parse.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Build.PL \
47         destdir=$RPM_BUILD_ROOT \
48         installdirs=vendor
49 ./Build
50
51 %{?with_tests:./Build test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 ./Build install
56
57 # for external HTML::TreeBuilder subclasses
58 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/HTML/TreeBuilder
59
60 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/HTML/Tree/*.pod
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README Changes
68 %attr(755,root,root) %{_bindir}/htmltree
69 %{perl_vendorlib}/HTML/AsSubs.pm
70 %{perl_vendorlib}/HTML/Element.pm
71 %{perl_vendorlib}/HTML/Parse.pm
72 %{perl_vendorlib}/HTML/Tree.pm
73 %{perl_vendorlib}/HTML/TreeBuilder.pm
74 %dir %{perl_vendorlib}/HTML/Element
75 %{perl_vendorlib}/HTML/Element/traverse.pm
76 %dir %{perl_vendorlib}/HTML/TreeBuilder
77 %{_mandir}/man1/htmltree.1*
78 %{_mandir}/man3/HTML::AsSubs.3pm*
79 %{_mandir}/man3/HTML::Element*.3pm*
80 %{_mandir}/man3/HTML::Parse.3pm*
81 %{_mandir}/man3/HTML::Tree*.3pm*
This page took 0.361938 seconds and 3 git commands to generate.