]> git.pld-linux.org Git - packages/perl-HTML-Template.git/blob - perl-HTML-Template.spec
5017a840aec74b8165ade285f413c1c7aaa2815b
[packages/perl-HTML-Template.git] / perl-HTML-Template.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    HTML
7 %define pnam    Template
8 Summary:        HTML::Template - Perl module to use HTML templates from CGI scripts
9 Summary(pl):    HTML::Template - modu³ Perla do obs³ugi szablonów HTML w skryptach CGI
10 Name:           perl-HTML-Template
11 Version:        2.6
12 Release:        2
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  dbd1c0c23fe323123deb9212c82a6f2d
17 URL:            http://html-template.sourceforge.net/
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 5.6.1
20 %if %{with tests}
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IPC-SharedCache
23 BuildRequires:  perl-Storable
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module attempts make using HTML templates simple and natural.
30
31 It extends standard HTML with a few new HTML-esque tags - <TMPL_VAR>,
32 <TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> and <TMPL_ELSE>.  The file written
33 with HTML and these new tags is called a template.  It is usually saved
34 separate from your script - possibly even created by someone else!
35
36 Using this module you fill in the values for the variables, loops and
37 branches declared in the template.  This allows you to seperate design -
38 the HTML - from the data, which you generate in the Perl script.
39
40 %description -l pl
41 HTML::Template jest modu³em pozwalaj±cym na wykorzystywanie szablonów
42 HTML (i nie tylko) w skryptach CGI (a tak¿e w dowolnym innym
43 oprogramowaniu przy tworzeniu którego zachodzi potrzeba rozdzielenia
44 programu od wygl±du danych.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:TEST_SHARED_MEMORY=1 TEST_FILE_CACHE=1 %{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/%{pdir}/%{pnam}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README ANNOUNCE FAQ templates scripts
69 %{perl_vendorlib}/%{pdir}/*.pm
70 %dir %{perl_vendorlib}/%{pdir}/%{pnam}
71 %{_mandir}/man3/*
This page took 0.093123 seconds and 2 git commands to generate.