]> git.pld-linux.org Git - packages/perl-HTML-TagReader.git/blob - perl-HTML-TagReader.spec
a50b9db58c2dcac486fdf967e4308d36b7a6ce07
[packages/perl-HTML-TagReader.git] / perl-HTML-TagReader.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    HTML
7 %define         pnam    TagReader
8 Summary:        HTML::TagReader - reading HTML/SGML/XML files by tags
9 Summary(pl.UTF-8):      HTML::TagReader - czytanie plików HTML/SGML/XML po znaczniku
10 Name:           perl-HTML-TagReader
11 Version:        1.10
12 Release:        11
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/HTML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a8e725be2877306454aecf31132cee08
18 URL:            http://search.cpan.org/dist/HTML-TagReader/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 # for tr_imgaddsize
22 Requires:       perl-Image-Size >= 2.0
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The module implements a fast and small object oriented way of
27 processing any kind of HTML/SGML/XML files by tag.
28
29 The getbytoken(0) is similar to while(<>) but instead of reading lines
30 it reads tags or tags and text.
31
32 HTML::TagReader makes it easy to keep track of the line number in a
33 file even though you are not reading the file by line. This important
34 if you want to implement error messages about HTML errors in your
35 code.
36
37 %description -l pl.UTF-8
38 Ten moduł implementuje szybką, obiektowo zorientowaną metodę
39 przetwarzania dowolnego rodzaju plików HTML/SGML/XML po znaczniku.
40
41 getbytoken(0) jest podobne do while(<>), ale zamiast czytania linii
42 czyta znaczniki lub znaczniki i tekst.
43
44 HTML::TagReader umożliwia łatwe śledzenie numeru linii w pliku nawet
45 jeśli nie jest on czytany po linii. Jest to ważne przy implementowaniu
46 komunikatów błędów dotyczących HTML-a.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54
55 %{__make} \
56         CC="%{__cc}" \
57         OPTIMIZE="%{rpmcflags}"
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %attr(755,root,root) %{_bindir}/tr_*
74 %{perl_vendorarch}/HTML/TagReader.pm
75 %dir %{perl_vendorarch}/auto/HTML/TagReader
76 %attr(755,root,root) %{perl_vendorarch}/auto/HTML/TagReader/TagReader.so
77 %{_mandir}/man[13]/*
This page took 0.040729 seconds and 2 git commands to generate.