]> git.pld-linux.org Git - SPECS.git/blob - perl-Google-ProtocolBuffers.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Google-ProtocolBuffers.spec
1 # Conditional build:
2 %bcond_without  tests           # do not perform "make test"
3
4 %define         pdir    Google
5 %define         pnam    ProtocolBuffers
6 Summary:        Google::ProtocolBuffers - simple interface to Google Protocol Buffers
7 Name:           perl-%{pdir}-%{pnam}
8 Version:        0.11
9 Release:        1
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
13 # Source0-md5:  f328b874b291018225201713054b3465
14 URL:            http://search.cpan.org/dist/Google-ProtocolBuffers/
15 BuildRequires:  perl-devel >= 1:5.8.0
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 %if %{with tests}
18 BuildRequires:  perl-Class-Accessor
19 %endif
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Google Protocol Buffers is a data serialization format. It is binary
25 (and hence compact and fast for serialization) and as extendable as
26 XML; its nearest analogues are Thrift and ASN.1. There are official
27 mappings for C++, Java and Python languages; this library is a mapping
28 for Perl.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make}
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} pure_install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 find $RPM_BUILD_ROOT -name .DS_Store | xargs -r rm -f
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %attr(755,root,root) %{_bindir}/*
57 %dir %{perl_vendorlib}/%{pdir}
58 %dir %{perl_vendorlib}/%{pdir}/%{pnam}
59 %{perl_vendorlib}/%{pdir}/*.pm
60 %{perl_vendorlib}/%{pdir}/%{pnam}/*.pm
61 %{_mandir}/man3/*
This page took 0.064361 seconds and 3 git commands to generate.