]> git.pld-linux.org Git - packages/perl-Gnome2.git/blob - perl-Gnome2.spec
- missing dir
[packages/perl-Gnome2.git] / perl-Gnome2.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test" (requires X server)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pnam    Gnome2
7 Summary:        Perl interface to the 2.x series of the Gnome libraries
8 Summary(pl):    Perlowy interfejs do bibliotek GNOME 2.x
9 Name:           perl-%{pnam}
10 Version:        0.30
11 Release:        0.1
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  8bf851c4864076c3ef0d74c9e5050ba4
16 BuildRequires:  gtk+2-devel
17 BuildRequires:  libgnomeui-devel >= 2.0.0
18 BuildRequires:  perl-Glib >= 0.95
19 BuildRequires:  perl-Gtk2 >= 0.95
20 BuildRequires:  perl-devel >= 5.8.0
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Gnome2 Perl module allows a perl developer to use the GNOME 2
27 libraries.
28
29 %description -l pl
30 Modu³ Perla Gnome2 pozwala programistom perlowym na u¿ywanie bibliotek
31 ¶rodowiska GNOME 2.
32
33 %prep
34 %setup -q -n %{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39
40 %{__make} \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?_with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc AUTHORS TODO README druid.pl
57 %{perl_vendorarch}/%{pnam}.pm
58 %dir %{perl_vendorarch}/auto/%{pnam}
59 %attr(755,root,root) %{perl_vendorarch}/auto/%{pnam}/*.so
60 %{perl_vendorarch}/auto/%{pnam}/*.bs
61 %{_mandir}/man3/*
This page took 0.051474 seconds and 3 git commands to generate.