]> git.pld-linux.org Git - SPECS.git/blob - perl-Gnome2-VFS.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Gnome2-VFS.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    Gnome2
6 %define         pnam    VFS
7 Summary:        Perl bindings for the GNOME Virtual File System
8 Summary(pl.UTF-8):      Dowiązania Perla dla biblioteki GNOME Virtual File System
9 Name:           perl-Gnome2-VFS
10 Version:        1.084
11 Release:        1
12 License:        LGPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        https://downloads.sourceforge.net/gtk2-perl/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  1dada72fb56a97e3397c9cb4304f81ab
16 URL:            http://gtk2-perl.sourceforge.net/
17 BuildRequires:  gnome-vfs2-devel >= 2.14.1
18 BuildRequires:  perl-ExtUtils-Depends >= 0.201
19 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
20 BuildRequires:  perl-Glib >= 1.120
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 Requires:       gnome-vfs2-libs >= 2.14.1
25 Requires:       perl-Glib >= 1.120
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The VFS module allows a perl developer to use the GNOME Virtual File
30 System.
31
32 Note: this module is deprecated and no longer maintained.
33
34 %description -l pl.UTF-8
35 Moduł VFS pozwala programistom perlowym na używanie biblioteki GNOME
36 Virtual File System.
37
38 Uwaga: ten moduł jest przestarzały i nie jest już utrzymywany.
39
40 %package devel
41 Summary:        Development files for Perl Gnome2-VFS bindings
42 Summary(pl.UTF-8):      Pliki programistyczne wiązań Gnome2-VFS dla Perla
43 Group:          Development/Languages/Perl
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gnome-vfs2-devel >= 2.14.1
46 Requires:       perl-Cairo-devel
47 Requires:       perl-Glib >= 1.120
48
49 %description devel
50 Development files for Perl Gnome2-VFS bindings.
51
52 %description devel -l pl.UTF-8
53 Pliki programistyczne wiązań Gnome2-VFS dla Perla.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61
62 %{__make} \
63         CC="%{__cc}" \
64         OPTIMIZE="%{rpmcflags}"
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} pure_install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Gnome2/VFS/{*,*/*,*/*/*}.pod
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc NEWS README
82 %{perl_vendorarch}/Gnome2/VFS.pm
83 %dir %{perl_vendorarch}/Gnome2/VFS
84 %dir %{perl_vendorarch}/auto/Gnome2/VFS
85 %attr(755,root,root) %{perl_vendorarch}/auto/Gnome2/VFS/VFS.so
86 %{_mandir}/man3/Gnome2::VFS*.3pm*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{perl_vendorarch}/Gnome2/VFS/Install
This page took 0.182133 seconds and 3 git commands to generate.