]> git.pld-linux.org Git - packages/perl-Geo-IP.git/blob - perl-Geo-IP.spec
362c3b397a6de31f5d322aa9216504be4454f309
[packages/perl-Geo-IP.git] / perl-Geo-IP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" 
4                         # (requires working DNS - but may fail anyway, because of some NXDOMAIN)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Geo
8 %define         pnam    IP
9 Summary:        Geo::IP - look up country by IP Address
10 Summary(pl):    Geo::IP - odszukanie kraju po adresie IP
11 Name:           perl-Geo-IP
12 Version:        1.25
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  ace222e93da3ee0af91f39fb3942b91d
19 BuildRequires:  GeoIP-devel
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module uses a file based database. This database simply contains
26 IP blocks as keys, and countries as values. This database should be
27 more complete and accurate than reverse DNS lookups.
28
29 This module can be used to automatically select the geographically
30 closest mirror, to analyze your web server logs to determine the
31 countries of your visitors, for credit card fraud detection, and for
32 software export controls.
33
34 %description -l pl
35 Ten modu³ u¿ywa bazy danych w postaci pliku. W bazie tej adresy IP s±
36 kluczami, a pañstwa warto¶ciami. Powinna ona byæ dok³adniejsza ni¿
37 sprawdzanie odwrotnego DNS.
38
39 Ta biblioteka mo¿e byæ u¿ywana do automatycznego wyboru najbli¿szego
40 geograficznie mirrora, analizy logów serwera WWW w celu okre¶lenia
41 kraju, z którego pochodz± odwiedzaj±cy, do wykrywania oszustw
42 dotycz±cych kart kredytowych oraz kontroli eksportu oprogramowania.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make} \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %dir %{perl_vendorarch}/Geo
69 %{perl_vendorarch}/Geo/*.pm
70 %dir %{perl_vendorarch}/Geo/IP
71 %{perl_vendorarch}/Geo/IP/*.pm
72 %dir %{perl_vendorarch}/auto/Geo
73 %dir %{perl_vendorarch}/auto/Geo/IP
74 %{perl_vendorarch}/auto/Geo/IP/IP.bs
75 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/IP/IP.so
76 %{_mandir}/man3/*
This page took 0.04209 seconds and 2 git commands to generate.