]> git.pld-linux.org Git - SPECS.git/blob - perl-Gearman-Server.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Gearman-Server.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Gearman
6 %define pnam    Server
7 Summary:        Gearman::Server - function call "router" and load balancer
8 Name:           perl-Gearman-Server
9 Version:        1.09
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/Gearman-Server-%{version}.tar.gz
15 # Source0-md5:  3d107089f7266ab91d66d9a7bd90430f
16 URL:            http://search.cpan.org/dist/Gearman-Server/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 You run a Gearman server (or more likely, many of them for both
24 high-availability and load balancing), then have workers (using
25 Gearman::Worker from the Gearman module, or libraries for other
26 languages) register their ability to do certain functions to all of
27 them, and then clients (using Gearman::Client, Gearman::Client::Async,
28 etc) request work to be done from one of the Gearman servers.
29
30 The servers connect them, routing function call requests to the
31 appropriate workers, multiplexing responses to duplicate requests as
32 requested, etc.
33
34 More than likely, you want to use the provided gearmand wrapper
35 script, and not use Gearman::Server directly.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc CHANGES
58 %{perl_vendorlib}/Gearman/*.pm
59 %{perl_vendorlib}/Gearman/Server
60 %{_mandir}/man3/*
61 %attr(755,root,root) %{_bindir}/gearmand
62 %{_mandir}/man1/*
This page took 0.122785 seconds and 3 git commands to generate.