]> git.pld-linux.org Git - SPECS.git/blob - perl-GSSAPI.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-GSSAPI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    GSSAPI
6 Summary:        GSSAPI - Perl extension providing access to the GSSAPIv2 library
7 Summary(pl.UTF-8):      GSSAPI - rozszerzenie Perla dające dostęp do biblioteki GSSAPIv2
8 Name:           perl-GSSAPI
9 Version:        0.28
10 Release:        16
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/A/AG/AGROLMS/GSSAPI-%{version}.tar.gz
15 # Source0-md5:  65f00a0749212af064289c8a05e59b3f
16 URL:            https://metacpan.org/dist/GSSAPI
17 BuildRequires:  heimdal-devel
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRequires:  which
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module gives access to the routines of the GSSAPI library, as
26 described in RFC 2743 and RFC 2744 and implemented by the Kerberos-1.2
27 distribution from MIT.
28
29 %description -l pl.UTF-8
30 Ten moduł daje dostęp do funkcji bibliotecznych GSSAPI określonych
31 przez RFC 2743 i RFC 2744 i zaimplementowanych przez MIT w dystrybucji
32 Kerberos-1.2.
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/GSSAPI.pm
62 %dir %{perl_vendorarch}/GSSAPI
63 %{perl_vendorarch}/GSSAPI/*.pm
64 %dir %{perl_vendorarch}/GSSAPI/OID
65 %{perl_vendorarch}/GSSAPI/OID/Set.pm
66 %dir %{perl_vendorarch}/auto/GSSAPI
67 %attr(755,root,root) %{perl_vendorarch}/auto/GSSAPI/GSSAPI.so
68 %{_mandir}/man3/GSSAPI*.3pm*
69 %{_examplesdir}/%{name}-%{version}
This page took 1.344816 seconds and 3 git commands to generate.