]> git.pld-linux.org Git - packages/perl-Font-FreeType.git/blob - perl-Font-FreeType.spec
perl 5.38.0 rebuild
[packages/perl-Font-FreeType.git] / perl-Font-FreeType.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Font
6 %define         pnam    FreeType
7 Summary:        Font::FreeType - read font files and render glyphs from Perl using FreeType2
8 Summary(pl.UTF-8):      Font::FreeType - odczyt plików fontów oraz rendering znaków graficznych za pomocą FreeType2
9 Name:           perl-Font-FreeType
10 Version:        0.16
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Font/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  01b17b1844c7369084288bb6c70b9021
17 URL:            https://metacpan.org/dist/Font-FreeType
18 BuildRequires:  freetype-devel >= 2
19 BuildRequires:  perl-Devel-CheckLib
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.64
21 BuildRequires:  perl-File-Which
22 %if %{with tests}
23 BuildRequires:  perl-Test-Warnings
24 %endif
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRequires:  rpmbuild(macros) >= 1.745
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module allows Perl programs to conveniently read information from
32 font files. All the font access is done through the FreeType2 library,
33 which supports many formats. It can render images of characters with
34 high-quality hinting and antialiasing, extract metrics information,
35 and extract the outlines of characters in scalable formats like
36 TrueType.
37
38 %description -l pl.UTF-8
39 Moduł ten umożliwia programom perlowym odczyt informacji z plików
40 fontów w wygodny sposób. Cały dostęp do fontów odbywa sie poprzez
41 bibliotekę FreeType2, która wspiera wiele formatów. Umożliwia
42 renderowanie obrazów znaków, wysokiej jakości hinting i antyaliasing,
43 pobieranie informacji o metryce oraz pobieranie zarysów znaków dla
44 formatów skalowalnych, takich jak TrueType.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %dir %{perl_vendorarch}/Font
70 %{perl_vendorarch}/Font/FreeType.pm
71 %{perl_vendorarch}/Font/FreeType
72 %dir %{perl_vendorarch}/auto/Font
73 %dir %{perl_vendorarch}/auto/Font/FreeType
74 %attr(755,root,root) %{perl_vendorarch}/auto/Font/FreeType/FreeType.so
75 %{_mandir}/man3/Font::FreeType*.3pm*
This page took 0.030119 seconds and 3 git commands to generate.