]> git.pld-linux.org Git - packages/perl-Font-FreeType.git/blob - perl-Font-FreeType.spec
- rebuild with perl 5.24.0
[packages/perl-Font-FreeType.git] / perl-Font-FreeType.spec
1 #
2 # TODO: check why tests fail (freetype expert needed)
3 #
4 # Conditional build:
5 %bcond_with     tests   # do perform "make test" (fails with recent freetype versions)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    Font
9 %define         pnam    FreeType
10 Summary:        Font::FreeType - read font files and render glyphs from Perl using FreeType2
11 Summary(pl.UTF-8):      Font::FreeType - odczyt plików fontów oraz rendering znaków graficznych za pomocą FreeType2
12 Name:           perl-Font-FreeType
13 Version:        0.03
14 Release:        12
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/Font/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  47b9483c92f1b2df0bbb5258a6a596b2
20 Patch0:         %{name}-gcc4.patch
21 URL:            http://search.cpan.org/dist/Font-FreeType/
22 BuildRequires:  freetype-devel >= 2
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module allows Perl programs to conveniently read information from
29 font files. All the font access is done through the FreeType2 library,
30 which supports many formats. It can render images of characters with
31 high-quality hinting and antialiasing, extract metrics information,
32 and extract the outlines of characters in scalable formats like
33 TrueType.
34
35 %description -l pl.UTF-8
36 Moduł ten umożliwia programom perlowym odczyt informacji z plików
37 fontów w wygodny sposób. Cały dostęp do fontów odbywa sie poprzez
38 bibliotekę FreeType2, która wspiera wiele formatów. Umożliwia
39 renderowanie obrazów znaków, wysokiej jakości hinting i antyaliasing,
40 pobieranie informacji o metryce oraz pobieranie zarysów znaków dla
41 formatów skalowalnych, takich jak TrueType.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 %patch0 -p1
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %dir %{perl_vendorarch}/Font
68 %{perl_vendorarch}/Font/FreeType.pm
69 %{perl_vendorarch}/Font/FreeType
70 %dir %{perl_vendorarch}/auto/Font
71 %dir %{perl_vendorarch}/auto/Font/FreeType
72 %attr(755,root,root) %{perl_vendorarch}/auto/Font/FreeType/FreeType.so
73 %{_mandir}/man3/Font::FreeType*.3pm*
This page took 0.08193 seconds and 3 git commands to generate.