]> git.pld-linux.org Git - SPECS.git/blob - perl-File-Temp.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-File-Temp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    File
6 %define pnam    Temp
7 #
8 Summary:        File::Temp - create name and handle of a temporary file safely
9 Summary(pl.UTF-8):      File::Temp - moduł języka Perl tworzący nazwy plików tymczasowych
10 Name:           perl-File-Temp
11 Version:        0.2309
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c089008cca0e6558e77d8403182bc521
17 URL:            http://search.cpan.org/dist/File-Temp/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 File::Temp can be used to create and open temporary files in a safe
26 way. There is both a function interface and an object-oriented
27 interface. The File::Temp constructor or the tempfile() function can
28 be used to return the name and the open filehandle of a temporary
29 file. The tempdir() function can be used to create a temporary
30 directory.
31
32 %description -l pl.UTF-8
33 File::Temp może być użyty do tworzenia i otwierania plików
34 tymczasowych w sposób bezpieczny. Istnieje zarówno interfejs
35 funkcyjny jak i obiektowy. Konstruktor klasy File::Temp lub funkcja
36 tempfile() mogą zwracać nazwę pliku tymczasowego a następnie go
37 otwierać do zapisu. Do tworzenia katalogów tymczasowych może być
38 użyta funkcja tempdir().
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %{perl_vendorlib}/File/Temp.pm
63 %{_mandir}/man3/File::Temp.3pm*
This page took 0.142032 seconds and 3 git commands to generate.