]> git.pld-linux.org Git - SPECS.git/blob - perl-File-Signature.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-File-Signature.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    File
6 %define pnam    Signature
7 Summary:        File::Signature - Detect changes to a file's content or attributes
8 Summary(pl.UTF-8):      File::Signature - wykrywa zmiany zawartości plików albo ich atrybutów
9 Name:           perl-File-Signature
10 Version:        1.009
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/J/JE/JEREMY/File-Signature-%{version}.tar.gz
16 # Source0-md5:  ef5baa7b8fcf50b8c3136810ca6aa964
17 URL:            http://search.cpan.org/dist/File-Signature/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module provides a way to monitor files for changes. It implements
27 an object oriented interface to file "signatures." In the case of this
28 module, a signature includes an MD5 digest (other digests may be added
29 later), the file's size, its inode number, its mode, its owner's uid,
30 its group's gid, and its mtime. This information is associated with a
31 file by the file's "pathname." The pathname is considered to be the
32 file's unique identifier. In reality, a file may have more than one
33 pathname, but this module doesn't recognize that. It will simply treat
34 two differing pathnames as two different files, even if they refer to
35 the same file.
36
37 As this module checks whether a file changes over time, a minimal use
38 of it would include the time when the signature was created and a
39 different time when the signature is regenerated and compared with the
40 previous one. The amount of time between these checks is arbitrary.
41 This module makes it easy to save a signature object and then load it
42 and check for consistency at a later time, whether seconds or years
43 have passed.
44
45 %description -l pl.UTF-8
46 Moduł ten wykrywa zmiany zawartości plików albo ich atrybutów.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/File/*.pm
71 %{_mandir}/man3/*
This page took 0.191943 seconds and 3 git commands to generate.