]> git.pld-linux.org Git - SPECS.git/blob - perl-File-Path-Expand.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-File-Path-Expand.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    File
6 %define         pnam    Path-Expand
7 Summary:        File::Path::Expand - expand filenames
8 Summary(pl.UTF-8):      File::Path::Expand - rozwijanie nazw plików
9 Name:           perl-File-Path-Expand
10 Version:        1.02
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  742aa40a4ffb26d14de01192764bd7ab
17 URL:            http://search.cpan.org/dist/File-Path-Expand/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 File::Path::Expand expands user directories in filenames. For the
28 simple case it's no more complex than s{^~/}{$HOME/}, but for other
29 cases it consults getpwent and does the right thing.
30
31 %description -l pl.UTF-8
32 File::Path::Expand rozwija katalogi użytkownika w nazwach plików. W
33 prostym przypadku nie jest to bardziej skomplikowane od
34 s{^~/}{$HOME/}, ale w innych wykorzystywana jest funkcja getpwent, aby
35 zrobić to co trzeba.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %{perl_vendorlib}/%{pdir}/*/*.pm
60 %{_mandir}/man3/*
This page took 0.269949 seconds and 3 git commands to generate.