]> git.pld-linux.org Git - packages/perl-File-Modified.git/blob - perl-File-Modified.spec
- converted to UTF-8
[packages/perl-File-Modified.git] / perl-File-Modified.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    File
7 %define pnam    Modified
8 Summary:        File::Modified - checks intelligently if files have changed
9 Summary(pl.UTF-8):   File::Modified - inteligentne sprawdzanie, czy pliki uległy zmianie
10 Name:           perl-File-Modified
11 Version:        0.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  271a991b96ccbdaeb7098272c9f97d51
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Modified module is intended as a simple method for programs to
25 detect whether configuration files (or modules they rely on) have
26 changed. There are currently two methods of change detection
27 implemented, mtime and MD5. The MD5 method will fall back to use
28 timestamps if the Digest::MD5 module cannot be loaded.
29
30 There is another module, File::Signature, which has many similar
31 features, so if this module doesn't do what you need, maybe
32 File::Signature does. There also is quite some overlap between the two
33 modules, code wise.
34
35 %description -l pl.UTF-8
36 Moduł Modified ma służyć programom za prostą metodę sprawdzania czy
37 pliki konfiguracyjne (lub moduły na których polegają) się zmieniły.
38 Aktualnie są zaimplementowane dwie metody sprawdzania zmian: mtime i
39 MD5. Metoda MD5 będzie działać jako mtime jeśli moduł Digest::MD5
40 będzie niedostępny.
41
42 Istnieje inny moduł - File::Signature - mający wiele podobnych cech,
43 więc jeśli ten moduł nie jest tym co potrzeba, może File::Signature
44 jest. Moduły te pokrywają się częściowo także pod względem kodu.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/File/*.pm
72 %{_mandir}/man3/*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.106699 seconds and 4 git commands to generate.