]> git.pld-linux.org Git - SPECS.git/blob - perl-FCGI-Engine.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-FCGI-Engine.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    FCGI
6 %define pnam    Engine
7 Summary:        FCGI::Engine - A flexible engine for running FCGI-based applications
8 Name:           perl-FCGI-Engine
9 Version:        0.21
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/FCGI/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  dd9a7a1c6977f915785e591143c31fe5
16 URL:            http://search.cpan.org/dist/FCGI-Engine/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Declare::Constraints::Simple)
21 BuildRequires:  perl(MooseX::Daemonize) >= 0.06
22 BuildRequires:  perl(MooseX::Getopt) >= 0.14
23 BuildRequires:  perl(MooseX::Types::Path::Class)
24 BuildRequires:  perl-CGI-Simple
25 BuildRequires:  perl-Config-Any
26 BuildRequires:  perl-FCGI
27 BuildRequires:  perl-Moose >= 0.32
28 BuildRequires:  perl-MooseX-AttributeHelpers >= 0.06
29 BuildRequires:  perl-Test-Exception
30 BuildRequires:  perl-Test-WWW-Mechanize
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This module helps manage FCGI based web applications by providing a
37 wrapper which handles most of the low-level FCGI details for you. It
38 can run FCGI programs as simple scripts or as full standalone socket
39 based servers who are managed by FCGI::Engine::ProcManager.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 # DEPRECATED use Plack::Handler::FCGI::Engine
58 %{__rm} -r $RPM_BUILD_ROOT%{perl_vendorlib}/Plack/Server
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/FCGI/*.pm
67 %{perl_vendorlib}/FCGI/Engine
68 %{perl_vendorlib}/Plack/Handler/FCGI
69 %{_mandir}/man3/*
This page took 0.187137 seconds and 3 git commands to generate.