]> git.pld-linux.org Git - packages/perl-Exception-Class.git/blob - perl-Exception-Class.spec
3cec1cb45ccd6063fb421df9a41ecd9ebdf88646
[packages/perl-Exception-Class.git] / perl-Exception-Class.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Exception
7 %define pnam    Class
8 Summary:        Exception::Class - declare real exception classes in Perl
9 Summary(pl):    Exception::Class - deklarowanie prawdziwych klas wyj±tków w Perlu
10 Name:           perl-Exception-Class
11 Version:        1.19
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2c0d924a18b7aae904883a5cffa6f9b4
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Data-Inheritable >= 0.02
22 BuildRequires:  perl-Devel-StackTrace >= 1.04
23 BuildRequires:  perl(Test::More) >= 0.46
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Exception::Class allows you to declare exceptions in your modules
30 in a manner similar to how exceptions are declared in Java.
31
32 %description -l pl
33 Exception::Class pozwala na deklarowanie w modu³ach wyj±tków
34 w sposób podobny do stosowanego w Javie.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README Changes LICENSE
58 %{perl_vendorlib}/Exception
59 %{_mandir}/man3/*
This page took 0.053662 seconds and 2 git commands to generate.