]> git.pld-linux.org Git - packages/perl-Encode-Detect.git/blob - perl-Encode-Detect.spec
356e77f0c27fb2dd81369a2010726d4cb2415101
[packages/perl-Encode-Detect.git] / perl-Encode-Detect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Encode
7 %define pnam    Detect
8 Summary:        Encode::Detect - An Encode::Encoding subclass that detects the encoding of data
9 Summary(pl.UTF-8):      Encode::Detect - podklasa Encode::Encoding wykrywająca kodowanie danych
10 Name:           perl-Encode-Detect
11 Version:        1.00
12 Release:        1
13 License:        MPL 1.1
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Encode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  54e03becd018e237c8ccc275b52df846
17 URL:            http://search.cpan.org/dist/Encode-Detect/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-Module-Build >= 0.2808
21 BuildRequires:  perl-ExtUtils-CBuilder
22 %if %{with tests}
23 BuildRequires:  perl-Data-Dump
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This Perl module is an Encode::Encoding subclass that uses
29 Encode::Detect::Detector to determine the charset of the input data
30 and then decodes it using the encoder of the detected charset.
31
32 It is similar to Encode::Guess, but does not require the configuration
33 of a set of expected encodings. Like Encode::Guess, it only supports
34 decoding - it cannot encode.
35
36 %description -l pl.UTF-8
37 Ten moduł Perla jest podklasą Encode::Encoding wykorzystującą
38 Encode::Detect::Detector do określenia zestawu znaków danych
39 wejściowych i dekodującą je przy użyciu kodera dla wykrytego zestawu
40 znaków.
41
42 Moduł ten jest podobny do Encode::Guess, ale nie wymaga konfiguracji
43 zbioru oczekiwanych kodowań. Podobnie jak Encode::Guess obsługuje
44 tylko dekodowanie; nie potrafi kodować.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Build.PL \
51         --extra-compiler-flags='%{rpmcflags} -x c++ -Iinclude' \
52         --destdir=$RPM_BUILD_ROOT \
53         --installdirs=vendor
54 ./Build
55
56 %{?with_tests:./Build test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 ./Build install
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes
69 %{perl_vendorarch}/Encode/*.pm
70 %{perl_vendorarch}/Encode/Detect
71 %dir %{perl_vendorarch}/auto/Encode/Detect
72 %dir %{perl_vendorarch}/auto/Encode/Detect/Detector
73 %attr(755,root,root) %{perl_vendorarch}/auto/Encode/Detect/Detector/*.so
74 %{_mandir}/man3/*
This page took 0.135217 seconds and 3 git commands to generate.