]> git.pld-linux.org Git - packages/perl-Email-Valid.git/blob - perl-Email-Valid.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Email-Valid.git] / perl-Email-Valid.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Email
6 %define         pnam    Valid
7 Summary:        Email::Valid - module determines whether an email address is valid
8 Summary(pl.UTF-8):      Email::Valid - moduł sprawdzający poprawność adresu e-mail
9 Name:           perl-Email-Valid
10 Version:        0.187
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  190b9293fde117c7f8ce30058c79745f
17 URL:            http://search.cpan.org/dist/Email-Valid/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-MailTools
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module determines whether an email address is well-formed, and
28 optionally, whether a mail host exists for the domain.
29
30 %description -l pl.UTF-8
31 Ten moduł sprawdza czy adres e-mail jest poprawnie zapisany i,
32 opcjonalnie, czy istnieje host przyjmujący pocztę.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Email/*.pm
57 %{_mandir}/man3/*
This page took 0.11336 seconds and 3 git commands to generate.