]> git.pld-linux.org Git - packages/perl-Email-Outlook-Message.git/blob - perl-Email-Outlook-Message.spec
use generic url
[packages/perl-Email-Outlook-Message.git] / perl-Email-Outlook-Message.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Email
6 %define pnam    Outlook-Message
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Email::Outlook::Message - MS Outlook .msg format converter
9 Summary(pl.UTF-8):      Email::Outlook::Message - konwerter formatu .msg Microsoft Outlooka
10 Name:           perl-Email-Outlook-Message
11 Version:        0.910
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/M/MV/MVZ/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f28708daf1521aecde05efef176cb37c
18 URL:            http://search.cpan.org/dist/Email-Outlook-Message/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(IO::All)
23 BuildRequires:  perl-Email-MIME >= 1.454
24 BuildRequires:  perl-Email-MIME-ContentType >= 1.014
25 BuildRequires:  perl-Email-Simple >= 2.003
26 BuildRequires:  perl-OLE-Storage_Lite >= 0.14
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Parses .msg message files as produced by Microsoft Outlook.
33
34 %description -l pl.UTF-8
35 Email::Outlook::Message - konwerter formatu .msg Microsoft Outlooka.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Build.PL \
42         destdir=$RPM_BUILD_ROOT \
43         installdirs=vendor
44 ./Build
45
46 %{?with_tests:./Build test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 ./Build install
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README TODO
59 %dir %{perl_vendorlib}/Email/Outlook
60 %{perl_vendorlib}/Email/Outlook/*.pm
61 %{_mandir}/man3/*
This page took 0.052158 seconds and 4 git commands to generate.