]> git.pld-linux.org Git - packages/perl-Dir-Purge.git/blob - perl-Dir-Purge.spec
864408c17593c859368fd825eb76db979db5a824
[packages/perl-Dir-Purge.git] / perl-Dir-Purge.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Dir
7 %define pnam    Purge
8 Summary:        Dir::Purge - Purge directories to a given number of files
9 Summary(pl):    Dir::Purge - czyszczenie katalogu do podanej liczby plików
10 Name:           perl-Dir-Purge
11 Version:        1.0
12 Release:        2
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 BuildRequires:  rpm-perlprov >= 4.0.2-104
18 %if %{?_without_tests:0}%{!?_without_tests:1}
19 BuildRequires:  perl(File::Path)
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Dir::Purge implements functions to reduce the number of files in a
26 directory according to a strategy. It currently provides one strategy:
27 removal of files by age.
28
29 %description -l pl
30 Modu³ Dir::Purge jest implementacj± funkcji zmniejszaj±cej liczbê
31 plików w katalogu zgodnie ze strategi±. Aktualnie obs³uguje jedn±
32 strategiê: usuwanie plików w zale¿no¶ci od ich wieku.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL
39 %{__make}
40
41 %{!?_without_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Change* README
54 %dir %{perl_sitelib}/Dir
55 %{perl_sitelib}/Dir/*.pm
56 %{_mandir}/man3/*
This page took 0.054698 seconds and 2 git commands to generate.