]> git.pld-linux.org Git - SPECS.git/blob - perl-Dir-Purge.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-Dir-Purge.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Dir
6 %define         pnam    Purge
7 Summary:        Dir::Purge - purge directories to a given number of files
8 Summary(pl.UTF-8):      Dir::Purge - czyszczenie katalogu do podanej liczby plików
9 Name:           perl-Dir-Purge
10 Version:        1.02
11 Release:        1
12 License:        GPL v2+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Dir/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d3dfb0af9e06b14f3e9017fa6257ecda
16 URL:            http://search.cpan.org/dist/Dir-Purge/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(File::Path)
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Dir::Purge implements functions to reduce the number of files in a
27 directory according to a strategy. It currently provides one strategy:
28 removal of files by age.
29
30 %description -l pl.UTF-8
31 Moduł Dir::Purge jest implementacją funkcji zmniejszającej liczbę
32 plików w katalogu zgodnie ze strategią. Aktualnie obsługuje jedną
33 strategię: usuwanie plików w zależności od ich wieku.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc CHANGES README
57 %dir %{perl_vendorlib}/Dir
58 %{perl_vendorlib}/Dir/*.pm
59 %{_mandir}/man3/*
This page took 0.141249 seconds and 3 git commands to generate.