]> git.pld-linux.org Git - packages/perl-Devel-Size.git/blob - perl-Devel-Size.spec
ec3666b95e8579f5bee8dc14f88a135475ccd8dc
[packages/perl-Devel-Size.git] / perl-Devel-Size.spec
1
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Devel
7 %define pnam    Size
8 Summary:        Devel::Size - Perl extension for finding the memory usage of Perl variables
9 Name:           perl-Devel-Size
10 Version:        0.58
11 Release:        1
12 # same as perl
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3043357cff650863b00cb54e511e38f0
17 BuildRequires:  perl-devel >= 5.6
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module figures out the real sizes of Perl variables in bytes.
23 Call functions with a reference to the variable you want the size
24 of.  If the variable is a plain scalar it returns the size of
25 the scalar.  If the variable is a hash or an array, use a reference
26 when calling.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make} \
35         OPTIMIZE="%{rpmcflags}"
36
37 %{?with_tests:make test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 make install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %{perl_vendorarch}/Devel/Size.pm
50 %{perl_vendorarch}/auto/Devel/Size/Size.bs
51 %attr(755,root,root) %{perl_vendorarch}/auto/Devel/Size/Size.so
52 %{_mandir}/man3/*
This page took 0.022186 seconds and 2 git commands to generate.