]> git.pld-linux.org Git - SPECS.git/blob - perl-Devel-REPL.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Devel-REPL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    REPL
7 Summary:        Devel::REPL - a modern perl interactive shell
8 Name:           perl-Devel-REPL
9 Version:        1.003012
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  bff993f2799b2e2cfbc89fbb74607106
15 URL:            http://search.cpan.org/dist/Devel-REPL/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-App-Nopaste
20 BuildRequires:  perl-B-Keywords
21 BuildRequires:  perl-Data-Dump-Streamer
22 BuildRequires:  perl-Data-Dumper-Concise
23 BuildRequires:  perl-File-HomeDir
24 BuildRequires:  perl-File-Next
25 BuildRequires:  perl-Lexical-Persistence
26 BuildRequires:  perl-Module-Refresh
27 BuildRequires:  perl-Moose >= 0.74
28 BuildRequires:  perl-MooseX-AttributeHelpers >= 0.16
29 BuildRequires:  perl-MooseX-Getopt >= 0.18
30 BuildRequires:  perl-MooseX-Object-Pluggable >= 0.0009
31 BuildRequires:  perl-PPI
32 BuildRequires:  perl-Sys-SigAction
33 BuildRequires:  perl-Task-Weaken
34 BuildRequires:  perl-namespace-clean
35 %endif
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This is an interactive shell for Perl, commonly known as a REPL -
41 Read, Evaluate, Print, Loop. The shell provides for rapid development
42 or testing of code without the need to create a temporary source code
43 file.
44
45 Through a plugin system, many features are available on demand. You
46 can also tailor the environment through the use of profiles and run
47 control files, for example to pre-load certain Perl modules when
48 working on a particular project.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %attr(755,root,root) %{_bindir}/re.pl
76 %{perl_vendorlib}/Devel/*.pm
77 %{perl_vendorlib}/Devel/REPL
78 %{_mandir}/man3/*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.973936 seconds and 3 git commands to generate.