]> git.pld-linux.org Git - packages/perl-Devel-Cycle.git/blob - perl-Devel-Cycle.spec
8075f252f514619ea5288e1be91fcc1e22ea1121
[packages/perl-Devel-Cycle.git] / perl-Devel-Cycle.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Devel
7 %define pnam    Cycle
8 Summary:        Devel::Cycle - Find memory cycles in objects
9 Summary(pl):    Devel::Cycle - znajdowanie cykli pamiêci w obiektach
10 Name:           perl-Devel-Cycle
11 Version:        1.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/L/LD/LDS/Devel-Cycle-%{version}.tar.gz
17 # Source0-md5:  7d8a1e0ca88f8a66bb1344a217d21f1c
18 URL:            http://search.cpan.org/dist/Devel-Cycle/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a simple developer's tool for finding circular references in
26 objects and other types of references. Because of Perl's
27 reference-count based memory management, circular references will
28 cause memory leaks.
29
30 %description -l pl
31 Ten pakiet zawiera proste narzêdzie dla programisty do znajdowania
32 zapêtlonych odniesieñ w obiektach i innych rodzajach referencji. W
33 wyniku perlowego zarz±dzania pamiêci± opartego o zliczanie odniesieñ
34 zapêtlone odniesienia powoduj± wycieki pamiêci.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Devel/*.pm
59 %{_mandir}/man3/*
This page took 0.102407 seconds and 2 git commands to generate.