]> git.pld-linux.org Git - packages/perl-DateTime-TimeZone.git/blob - perl-DateTime-TimeZone.spec
ff1380fe42ae06711acfae18135a42a002b3a7a9
[packages/perl-DateTime-TimeZone.git] / perl-DateTime-TimeZone.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DateTime
7 %define         pnam    TimeZone
8 Summary:        DateTime::TimeZone - time zone object base class and factory
9 Summary(pl.UTF-8):      DateTime::TimeZone - podstawowe klasy obiektowe do obsługi stref czasowych
10 Name:           perl-DateTime-TimeZone
11 Version:        1.01
12 Release:        1
13 Epoch:          3
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  01685db9a295042c29e038f62fed8cd7
19 URL:            http://search.cpan.org/dist/DateTime-TimeZone/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 # most tests skipped without DateTime >= 0.1501
25 BuildRequires:  perl-DateTime >= 0.15_01
26 BuildRequires:  perl-Params-Validate >= 0.72
27 %endif
28 Requires:       perl-Class-Singleton >= 1.03
29 Requires:       perl-Params-Validate >= 0.72
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreq      'perl(DateTime::TimeZone.*)'
34
35 %description
36 This class is the base class for all time zone objects. A time
37 zone is represented internally as a set of observances, each
38 of which describes the offset from GMT for a given time period.
39 Note that without the "DateTime.pm" module, this module does not
40 do much. It's primary interface is through a "DateTime" object,
41 and most users will not need to directly use "DateTime::TimeZone"
42 methods.
43
44 %description -l pl.UTF-8
45 Jest to klasa bazowa dla klas wszystkich obiektów stref czasowych.
46 Strefa czasowa jest reprezentowana przez zbiór reguł, z których każda
47 określa przesunięcie o zadany okres czasu w stosunku do czasu
48 uniwersalnego (GMT). Należy zwrócić uwagę, że bez modułu "DateTime.pm"
49 moduł ten nie jest w stanie wiele zdziałać. Jego podstawowym
50 interfejsem jest moduł "DateTime" i w większości przypadków nie ma
51 potrzeby bezpośredniego korzystania z metod "DateTime::TimeZone".
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55
56 %build
57 %{__perl} Build.PL \
58         installdirs=vendor \
59         destdir=$RPM_BUILD_ROOT
60 ./Build
61
62 %{?with_tests:./Build test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 ./Build install
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %{perl_vendorlib}/DateTime/*.pm
75 %{perl_vendorlib}/DateTime/TimeZone
76 %{_mandir}/man3/*
This page took 0.070416 seconds and 2 git commands to generate.