]> git.pld-linux.org Git - packages/perl-DateTime-TimeZone.git/blob - perl-DateTime-TimeZone.spec
34c8a8aa5861387e4cdd5e8204a9d3f5d77bf6cd
[packages/perl-DateTime-TimeZone.git] / perl-DateTime-TimeZone.spec
1 # TODO:
2 # - Fix so it builds with tests
3 #
4 # Conditional build:
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    DateTime
9 %define         pnam    TimeZone
10 Summary:        DateTime::TimeZone - time zone object base class and factory
11 Summary(pl.UTF-8):      DateTime::TimeZone - podstawowe klasy obiektowe do obsługi stref czasowych
12 Name:           perl-DateTime-TimeZone
13 Version:        1.26
14 Release:        0.1
15 Epoch:          3
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  4a5b5e90044f4a1736c214386d0bc7f8
21 URL:            http://search.cpan.org/dist/DateTime-TimeZone/
22 BuildRequires:  perl-Module-Build
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 %if %{with tests}
26 # most tests skipped without DateTime >= 0.1501
27 BuildRequires:  perl-DateTime >= 0.15_01
28 BuildRequires:  perl-Params-Validate >= 0.72
29 %endif
30 Requires:       perl-Class-Singleton >= 1.03
31 Requires:       perl-Params-Validate >= 0.72
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreq      'perl(DateTime::TimeZone.*)'
36
37 %description
38 This class is the base class for all time zone objects. A time zone is
39 represented internally as a set of observances, each of which
40 describes the offset from GMT for a given time period. Note that
41 without the "DateTime.pm" module, this module does not do much. It's
42 primary interface is through a "DateTime" object, and most users will
43 not need to directly use "DateTime::TimeZone" methods.
44
45 %description -l pl.UTF-8
46 Jest to klasa bazowa dla klas wszystkich obiektów stref czasowych.
47 Strefa czasowa jest reprezentowana przez zbiór reguł, z których każda
48 określa przesunięcie o zadany okres czasu w stosunku do czasu
49 uniwersalnego (GMT). Należy zwrócić uwagę, że bez modułu "DateTime.pm"
50 moduł ten nie jest w stanie wiele zdziałać. Jego podstawowym
51 interfejsem jest moduł "DateTime" i w większości przypadków nie ma
52 potrzeby bezpośredniego korzystania z metod "DateTime::TimeZone".
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Build.PL \
59         installdirs=vendor \
60         destdir=$RPM_BUILD_ROOT
61 ./Build
62
63 %{?with_tests:./Build test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 ./Build install
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %{perl_vendorlib}/DateTime/*.pm
76 %{perl_vendorlib}/DateTime/TimeZone
77 %{_mandir}/man3/*
This page took 0.09084 seconds and 2 git commands to generate.