]> git.pld-linux.org Git - SPECS.git/blob - perl-DateTime-Set.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-DateTime-Set.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DateTime
6 %define pnam    Set
7 Summary:        DateTime::Set - datetime sets and set math
8 Summary(pl.UTF-8):      DateTime::Set - zbiory czasów i matematyka na zbiorach
9 Name:           perl-DateTime-Set
10 Version:        0.3900
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e711661bf8e2d79cb9a5911285dfbf15
17 URL:            http://search.cpan.org/dist/DateTime-Set/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-DateTime >= 0.12
23 BuildRequires:  perl-DateTime-Locale
24 BuildRequires:  perl-DateTime-TimeZone
25 BuildRequires:  perl-Exporter-Tiny
26 BuildRequires:  perl-Module-Implementation
27 BuildRequires:  perl-Params-Validate
28 BuildRequires:  perl-Set-Infinite >= 0.59
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 DateTime::Set is a module for datetime sets. It can be used to handle
35 two different types of sets.
36
37 The first is a fixed set of predefined datetime objects. For example,
38 if we wanted to create a set of datetimes containing the birthdays of
39 people in our family.
40
41 The second type of set that it can handle is one based on the idea of
42 a recurrence, such as "every Wednesday", or "noon on the 15th day of
43 every month". This type of set can have fixed starting and ending
44 datetimes, but neither is required. So our "every Wednesday set" could
45 be "every Wednesday from the beginning of time until the end of time",
46 or "every Wednesday after 2003-03-05 until the end of time", or "every
47 Wednesday between 2003-03-05 and 2004-01-07".
48
49 %description -l pl.UTF-8
50 DateTime::Set to moduł do zbiorów czasów. Może być używany do obsługi
51 dwóch różnych rodzajów zbiorów.
52
53 Pierwszy to stały zbiór predefiniowanych obiektów czasu (datetime). Na
54 przykład jeśli chcemy stworzyć zbiór czasów zawierający urodziny osób
55 z naszej rodziny.
56
57 Drugi rodzaj zbiorów obsługiwany przez ten moduł jest oparty na idei
58 rekurencji, takiej jak "każda środa" lub "południe 15 dnia każdego
59 miesiąca". Ten rodzaj zbioru może mieć stałe czasy początkowe i
60 końcowe, ale żaden z nich nie jest wymagany. Tak więc "zbiór
61 wszystkich śród" może być "każdą środą od początku czasu do końca
62 czasu" lub "każdą środą po 2003-03-05 do końca czasu" lub "każdą środą
63 między 2003-03-05 a 2004-01-07".
64
65 %prep
66 %setup -q -n %{pdir}-%{pnam}-%{version}
67 %{__sed} -i -e 's/use Set::Infinite 0.5502/use Set::Infinite 0.55_02/' lib/Set/Infinite/_recurrence.pm
68
69 %build
70 %{__perl} Build.PL \
71         destdir=$RPM_BUILD_ROOT \
72         installdirs=vendor
73 ./Build
74
75 %{?with_tests:./Build test}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 ./Build install
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc Changes README TODO
88 %{perl_vendorlib}/DateTime/*.pm
89 %{perl_vendorlib}/Set/Infinite/_recurrence.pm
90 %{_mandir}/man3/*
This page took 0.397342 seconds and 3 git commands to generate.