]> git.pld-linux.org Git - packages/perl-DateTime-Format-Builder.git/blob - perl-DateTime-Format-Builder.spec
- updated to 0.80 (epoch 1)
[packages/perl-DateTime-Format-Builder.git] / perl-DateTime-Format-Builder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 %define pnam    Format-Builder
8 Summary:        DateTime::Format::Builder - Create DateTime parser classes and objects
9 Summary(pl.UTF-8):      DateTime::Format::Builder - tworzenie klas i obiektów analizatorów DateTime
10 Name:           perl-DateTime-Format-Builder
11 Version:        0.80
12 Release:        1
13 Epoch:          1
14 # same as perl 5.000 or later perl 5
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/DateTime/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  f6c5d5a17b5b7478ff555a2d3cce5136
19 URL:            http://search.cpan.org/dist/DateTime-Format-Builder/
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Class-Factory-Util >= 1.6
25 BuildRequires:  perl-DateTime >= 0.12
26 BuildRequires:  perl-DateTime-Format-Strptime >= 1.04
27 BuildRequires:  perl-Params-Validate >= 0.72
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 DateTime::Format::Builder creates DateTime parsers. Many string
34 formats of dates and times are simple and just require a basic
35 regular expression to extract the relevant information. Builder
36 provides a simple way to do this without writing reams of structural
37 code.
38
39 Builder provides a number of methods, most of which you'll never need,
40 or at least rarely need. They're provided more for exposing of the
41 module's innards to any subclasses, or for when you need to do
42 something slightly beyond what I expected.
43
44 %description -l pl.UTF-8
45 DateTime::Format::Builder tworzy analizatory DateTime. Wiele formatów
46 łańcuchów dat i czasu jest prostych i do wyciągnięcia istotnych
47 informacji wymaga jedynie prostego wyrażenia regularnego. Builder
48 udostępnia prosty sposób wykonania tego bez pisania większego kodu
49 strukturalnego.
50
51 Builder udostępnia wiele metod, z których większości się nie używa lub
52 używa bardzo rzadko. Są udostępnione bardziej dla ukazania wnętrzności
53 modułu dla podklas albo w razie potrzeby zrobienia czegoś więcej niż
54 oczekiwał autor.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Build.PL \
61         destdir=$RPM_BUILD_ROOT \
62         installdirs=vendor
63 ./Build
64
65 %{?with_tests:./Build test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 ./Build install
71
72 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74
75 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/Format/Builder.pod
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS CREDITS Changes LICENCE
83 %{perl_vendorlib}/DateTime/Format/Builder.pm
84 %{perl_vendorlib}/DateTime/Format/Builder
85 %{_mandir}/man3/DateTime::Format::Builder*.3pm*
86 %{_examplesdir}/%{name}-%{version}
This page took 0.107566 seconds and 4 git commands to generate.