]> git.pld-linux.org Git - packages/perl-DateTime-Format-Builder.git/blob - perl-DateTime-Format-Builder.spec
- new
[packages/perl-DateTime-Format-Builder.git] / perl-DateTime-Format-Builder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 %define pnam    Format-Builder
8 Summary:        DateTime::Format::Builder - Create DateTime parser classes and objects.
9 #Summary(pl.UTF-8):     
10 Name:           perl-DateTime-Format-Builder
11 Version:        0.7807
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/D/DR/DROLSKY/DateTime-Format-Builder-0.7807.tar.gz
17 # Source0-md5:  4f6ee670cab944db0492e70ca8df3be3
18 URL:            http://search.cpan.org/dist/DateTime-Format-Builder/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Class::Factory::Util) >= 1.6
23 BuildRequires:  perl(DateTime) >= 0.12
24 BuildRequires:  perl(DateTime::Format::Strptime) >= 1.04
25 BuildRequires:  perl(Params::Validate) >= 0.72
26 BuildRequires:  perl(Module::Build)
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 DateTime::Format::Builder creates DateTime parsers.
33 Many string formats of dates and times are simple and just
34 require a basic regular expression to extract the relevant
35 information. Builder provides a simple way to do this
36 without writing reams of structural code.
37
38 Builder provides a number of methods, most of which you'll
39 never need, or at least rarely need. They're provided more
40 for exposing of the module's innards to any subclasses, or
41 for when you need to do something slightly beyond what I
42 expected.
43
44 # %description -l pl.UTF-8
45 # TODO
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Build.PL \
52         destdir=$RPM_BUILD_ROOT \
53         installdirs=vendor
54 ./Build
55
56 %{?with_tests:./Build test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 ./Build install
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS Changes CREDITS INSTALL README
72 %{perl_vendorlib}/DateTime/Format/*.pm
73 %{perl_vendorlib}/DateTime/Format/Builder
74 %{_mandir}/man3/*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.059175 seconds and 4 git commands to generate.