]> git.pld-linux.org Git - packages/perl-Date-Simple.git/blob - perl-Date-Simple.spec
- rel. 2
[packages/perl-Date-Simple.git] / perl-Date-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Date
7 %define pnam    Simple
8 Summary:        Date::Simple - a simple date object
9 Summary(pl):    Date::Simple - prosty obiekt daty
10 Name:           perl-Date-Simple
11 Version:        3.01
12 Release:        2
13 License:        GPL v2+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  66133a8738dd7ef46f7008339a86f41d
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module may be used to create simple date objects. It only handles
24 dates within the range of Unix time. It will only allow the creation
25 of objects for valid dates. Attempting to create an invalid date will
26 return undef.
27
28 %description -l pl
29 Ten modu³ mo¿e byæ u¿ywany do tworzenia prostych obiektów daty.
30 Obs³uguje tylko daty z uniksowego przedzia³u czasu. Pozwala stworzyæ
31 obiekty tylko dla poprawnych dat - przy próbie stworzenia b³êdnej daty
32 zwróci undef.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL noxs \
39         INSTALLDIRS=vendor
40
41 %{__make}
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README
56 %{perl_vendorlib}/Date/Simple.pm
57 %{perl_vendorlib}/Date/Simple
58 %{_mandir}/man3/*
This page took 0.065384 seconds and 4 git commands to generate.