]> git.pld-linux.org Git - packages/perl-Date-Pcalc.git/blob - perl-Date-Pcalc.spec
- added missing %dirs in %files section
[packages/perl-Date-Pcalc.git] / perl-Date-Pcalc.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Date
7 %define         pnam    Pcalc
8 Summary:        Date::Pcalc Perl module - Gregorian calendar date calculations
9 Summary(pl.UTF-8):      Moduł Perla Date::Pcalc - obliczenia na datach wg kalendarza gregoriańskiego
10 Name:           perl-Date-Pcalc
11 Version:        6.1
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6a719d8fe10ac673be5d09e003130aa8
18 URL:            http://catcode.com/date/pcalc.html
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Bit-Vector >= 7.1
23 BuildRequires:  perl-Carp-Clan >= 5.3
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      'perl(anything_fake_or_conditional)'
28
29 %description
30 This package consists of a Perl module for all kinds of date
31 calculations based on the Gregorian calendar (the one used in all
32 western countries today), thereby complying with all relevant norms
33 and standards: ISO/R 2015-1971, DIN 1355 and, to some extent, ISO 8601
34 (where applicable).
35
36 %description -l pl.UTF-8
37 Ten pakiet zawiera moduł Perla do wszystkich rodzajów obliczeń na
38 datach opartych na kalendarzu gregoriańskim (używanym aktualnie we
39 wszystkich państwach zachodnich) w sposób zgodny z odpowiednimi
40 normami i standardami: ISO/R 2015-1971, DIN 1355 i, w pewnym zakresie,
41 ISO 8601.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -a tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CHANGES.txt CREDITS.txt INSTALL.txt README.txt EXAMPLES.txt
71 %dir %{perl_vendorarch}/Date
72 %{perl_vendorarch}/Date/*.pm
73 %dir %{perl_vendorarch}/Date/Pcalc
74 %{perl_vendorarch}/Date/Pcalc/Object.pm
75 %{perl_vendorarch}/Date/Pcalendar.pm
76 %dir %{perl_vendorarch}/Date/Pcalendar
77 %{perl_vendorarch}/Date/Pcalendar/*.pm
78 %dir %{perl_vendorarch}/auto/Date
79 %dir %{perl_vendorarch}/auto/Date/Pcalc
80 %{perl_vendorarch}/auto/Date/Pcalc/*.bs
81 %attr(755,root,root) %{perl_vendorarch}/auto/Date/Pcalc/*.so
82 %{_mandir}/man3/*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.119605 seconds and 4 git commands to generate.