]> git.pld-linux.org Git - packages/perl-Data-UUID.git/blob - perl-Data-UUID.spec
- new
[packages/perl-Data-UUID.git] / perl-Data-UUID.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Data
7 %define         pnam    UUID
8 Summary:        Data::UUID - Perl extension for generating GUIDs/UUIDs
9 Summary(pl):    Data::UUID - rozszerzenie Perla do generacji GUID-ów/UUID-ów
10 Name:           perl-Data-UUID
11 Version:        0.08
12 Release:        1
13 License:        ?
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 BuildRequires:  rpm-perlprov >= 3.0.3-16
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This module provides a framework for generating UUIDs (Universally
22 Unique Identifiers, also known as GUIDs (Globally Unique Identifiers).
23 A UUID is 128 bits long, and is guaranteed to be different from all
24 other UUIDs/GUIDs generated until 3400 A.D. UUIDs were originally used
25 in the Network Computing System (NCS) and later in the Open Software
26 Foundation's (OSF) Distributed Computing Environment. Currently many
27 different technologies rely on UUIDs to provide unique identity for
28 various software components.
29
30 %description -l pl
31 Modu³ Perla Data::UUID udostêpnia szkielet generacji UUID-ów
32 (Universally Unique Identifiers - identyfikatorów unikalnych
33 powszechnie), znanych tez jako GUID-y (Globally Unique Identifiers -
34 identyfikatory unikalne globalnie). UUID-y s± 128-bitowe i
35 gwarantowana jest ich unikalno¶æ w¶ród wszyskich innych UUID-ów/
36 /GUID-ów wygenerowanych do roku 3400. UUID-y pierwotnie by³y u¿ywane w
37 (Network Computing System (NCS), a pó¼niej w Rozproszonym ¦rodowisku
38 Obliczeniowym (Distributed Computing Environment) Fundacji Open
39 Software (OSF). Obecnie na zagwarantowanych przez UUID-y unikalnych
40 identyfikatorach dla ró¿nych sk³adników oprogramowania opartych jest
41 wiele ró¿nych technologii
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 # Don't use pipes here: they generally don't work. Apply a patch.
48 perl Makefile.PL </dev/null
49 %{__make} OPTIMIZE="%{rpmcflags}"
50
51 %{!?_without_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_sitearch}/Data/UUID.pm
66 %dir %{perl_sitearch}/auto/Data/UUID
67 %{perl_sitearch}/auto/Data/UUID/UUID.bs
68 %attr(755,root,root) %{perl_sitearch}/auto/Data/UUID/UUID.so
69 %{_mandir}/man3/*
This page took 0.059939 seconds and 3 git commands to generate.