]> git.pld-linux.org Git - packages/perl-Data-TemporaryBag.git/blob - perl-Data-TemporaryBag.spec
-new spec
[packages/perl-Data-TemporaryBag.git] / perl-Data-TemporaryBag.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Data
7 %define pnam    TemporaryBag
8 Summary:        Data::TemporaryBag - Handle long size data using temporary file.
9 Name:           perl-Data-TemporaryBag
10 Version:        0.08
11 Release:        0.2
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 BuildRequires:  perl-devel >= 1:5.8.0
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _noautoreq      'perl(anything_fake_or_conditional)'
21
22 %description
23 Data::TemporaryBag module provides a bag object class handling long
24 size data. The short size data are kept on memory. When the data size
25 becomes over $Threshold size, they are saved into a temporary file
26 internally.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 # Don't use pipes here: they generally don't work. Apply a patch.
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35
36 %{__make}
37 # if module isn't noarch, use:
38 # %{__make} \
39 #       OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 # use macros:
56 %{perl_vendorlib}/*
57 %{perl_vendorarch}/*
58 %{_mandir}/man3/*
This page took 0.089584 seconds and 4 git commands to generate.