]> git.pld-linux.org Git - packages/perl-Data-Taxi.git/blob - perl-Data-Taxi.spec
- new
[packages/perl-Data-Taxi.git] / perl-Data-Taxi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Data
7 %define         pnam    Taxi
8 Summary:        Data::Taxi - Taint-aware, XML-ish data serialization
9 Name:           perl-Data-Taxi
10 Version:        0.94
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5d7c981fba542ae8b170e6d31af4c86d
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Taxi (Taint-Aware XML-Ish) is a data serializer with several handy features:
24 - Taint aware. Taxi does not force you to trust the data you are serializing. None of the input data is executed.
25 - Human readable. Taxi produces a human-readable string that simplifies checking the output of your objects.
26 - XML-ish. While full XML compliance is not promised, Taxi produces a block of XML-ish data that could probably be read in by other XML parsers.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make}
35 %{?with_tests:%{__make} test}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README
49 %{perl_vendorlib}/Data/Taxi.pm
50 %{_mandir}/man3/*
This page took 0.056908 seconds and 4 git commands to generate.