]> git.pld-linux.org Git - SPECS.git/blob - perl-Data-Structure-Util.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Data-Structure-Util.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define pdir    Data
6 %define pnam    Structure-Util
7 Summary:        Data::Structure::Util - Change nature of data within a structure
8 Summary(pl.UTF-8):      Data::Structure::Util - Zmiana natury danych wewnątrz struktury
9 Name:           perl-%{pdir}-%{pnam}
10 Version:        0.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e12ba777c0abfbd79a131de28d542359
17 URL:            http://search.cpan.org/dist/Data-Structure-Util/
18 %if %{with tests}
19 BuildRequires:  perl-Clone
20 BuildRequires:  perl-File-Find-Rule
21 BuildRequires:  perl-Test-Pod
22 %endif
23 BuildRequires:  perl-Module-Build >= 0.02
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Data::Structure::Util is a toolbox to manipulate data inside a data
30 structure. It can parse an entire tree and perform the operation
31 requested on each appropriate element. It can transform to UTF-8 any
32 string within a data structure. I can attempt to transform any UTF-8
33 string back to default encoding either. It can remove the blessing on
34 any reference. It can collect all the objects or detect if there is a
35 circular reference.
36
37 It is written in C for decent speed.
38
39 %description -l pl.UTF-8
40 Data::Structure::Util to zestaw narzędzi do obróbki danych wewnątrz
41 struktur danych. Może analizować całe drzewo i wykonywać żądane
42 operacje na każdym właściwym elemencie. Może przekształcać na UTF-8
43 dowolny łańcuch wewnątrz struktury danych, a także próbować
44 przekształcić dowolny łańcuch z UTF-8 z powrotem do domyślnego
45 kodowania. Może usuwać błogosławieństwo z dowolnej referencji. Może
46 zbierać wszystkie obiekty lub wykrywać czy są zapętlone referencje.
47
48 Jest napisany w C w celu zapewnienia przyzwoitej szybkości.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56
57 %{__make} \
58         CC="%{__cc}" \
59         OPTIMIZE="%{rpmcflags}"
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
68
69 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Data/Structure/Util/.packlist
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc CHANGES README
77 %dir %{perl_vendorarch}/Data/Structure
78 %{perl_vendorarch}/Data/Structure/Util.pm
79 %dir %{perl_vendorarch}/auto/Data/Structure
80 %dir %{perl_vendorarch}/auto/Data/Structure/Util
81 %{perl_vendorarch}/auto/Data/Structure/Util/autosplit.ix
82 %attr(755,root,root) %{perl_vendorarch}/auto/Data/Structure/Util/Util.so
83 %{_mandir}/man3/*
This page took 0.567194 seconds and 3 git commands to generate.