]> git.pld-linux.org Git - SPECS.git/blob - perl-DBIx-Simple.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / perl-DBIx-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    DBIx
6 %define         pnam    Simple
7 Summary:        DBIx::Simple - Very complete easy-to-use OO interface to DBI
8 Name:           perl-DBIx-Simple
9 Version:        1.37
10 Release:        1
11 License:        Any from http://www.opensource.org/licenses/alphabetical
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  eb53ef4a93be7ebf043cd49075e81913
15 URL:            https://metacpan.org/release/DBIx-Simple
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  rpmbuild(macros) >= 1.745
19 %if %{with tests}
20 BuildRequires:  perl-DBI >= 1.21
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 DBIx::Simple provides a simplified interface to DBI, Perl's powerful
27 database module.
28
29 This module is aimed at rapid development and easy maintenance. Query
30 preparation and execution are combined in a single method, the result
31 object (which is a wrapper around the statement handle) provides easy
32 row-by-row and slurping methods.
33
34 The query method returns either a result object, or a dummy object.
35 The dummy object returns undef (or an empty list) for all methods and
36 when used in boolean context, is false. The dummy object lets you
37 postpone (or skip) error checking, but it also makes immediate error
38 checking simply $db->query(...) or die $db->error.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/DBIx/Simple.pm
63 %{perl_vendorlib}/DBIx/Simple
64 %{_mandir}/man3/DBIx::Simple*.3*
This page took 1.219329 seconds and 3 git commands to generate.