]> git.pld-linux.org Git - SPECS.git/blob - perl-DBIx-SQLEngine.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-DBIx-SQLEngine.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working DBI connection)
4
5 %define         pdir    DBIx
6 %define         pnam    SQLEngine
7 Summary:        DBIx::SQLEngine - extends DBI with high-level operations
8 Summary(pl.UTF-8):      DBIx::SQLEngine - rozszerzenie DBI o wysokopoziomowe operacje
9 Name:           perl-DBIx-SQLEngine
10 Version:        0.93
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  963f4e41b77f7a1f6287eeac760a94e1
17 URL:            http://search.cpan.org/dist/DBIx-SQLEngine/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-MakeMethods >= 1.003
22 BuildRequires:  perl-Class-MakeMethods-Template >= 1.003
23 BuildRequires:  perl-DBI >= 1.0
24 BuildRequires:  perl-DBIx-AnyDBD >= 2.0
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The DBIx::SQLEngine class provides an extended interface for the DBI
31 database interface, adding methods that support ad-hoc SQL generation
32 and query execution in a single call.
33
34 %description -l pl.UTF-8
35 Klasa DBIx::SQLEngine udostępnia rozszerzony interfejs dla interfejsu
36 bazodanowego DBI, dodając metody obsługujące generowanie SQL w locie i
37 wykonywanie zapytań w pojedynczym wywołaniu.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorlib}/DBIx/*.pm
61 %dir %{perl_vendorlib}/DBIx/SQLEngine
62 %{perl_vendorlib}/DBIx/SQLEngine/*.pm
63 %{perl_vendorlib}/DBIx/SQLEngine/Cache
64 %{perl_vendorlib}/DBIx/SQLEngine/Criteria
65 %{perl_vendorlib}/DBIx/SQLEngine/Driver
66 %{perl_vendorlib}/DBIx/SQLEngine/Record
67 %{perl_vendorlib}/DBIx/SQLEngine/RecordSet
68 %{perl_vendorlib}/DBIx/SQLEngine/Schema
69 %{perl_vendorlib}/DBIx/SQLEngine/Utility
70 %{_mandir}/man3/*
This page took 0.797367 seconds and 3 git commands to generate.