]> git.pld-linux.org Git - packages/perl-DBI.git/blob - perl-DBI.spec
- use the __perl macro
[packages/perl-DBI.git] / perl-DBI.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DBI
7 %define pnam    DBI
8 Summary:        DBI - Database independent interface for Perl
9 Summary(pl):    DBI - niezale¿ny interfejs baz danych dla perla
10 Name:           perl-DBI
11 Version:        1.32
12 Release:        2
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
16 Patch0:         perl-DBI-changes.patch
17 BuildRequires:  rpm-perlprov >= 3.0.3-16
18 BuildRequires:  perl >= 5.6.1
19 %if %{?_with_tests:1}%{!?_with_tests:0}
20 BuildRequires:  perl-PlRPC
21 BuildRequires:  perl-Storable
22 BuildRequires:  perl-Net-Daemon
23 %endif
24 Obsoletes:      perl-DBI-FAQ
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      'perl(DBD::<foo>)' 'perl(DBI::Format)' 'perl(DBI::PurePerl)'
28 %define         _noautoreqdep   'perl(UNIVERSAL)'
29
30 %description
31 The DBI is a database access module for the Perl programming language.
32 It defines a set of methods, variables, and conventions that provide
33 a consistent database interface, independent of the actual database
34 being used.
35
36 %description -l pl
37 DBI jest modu³em dostêpu do baz danych dla Perla.  Definiuje grupê metod,
38 zmiennych i konwencji, zapewniaj±cych spójny interfejs do baz danych,
39 niezale¿ny od typu aktualnie u¿ywanej bazy.
40
41 %prep
42 %setup -q -n %{pnam}-%{version}
43 %patch0 -p0
44
45 %build
46 %{__perl} Makefile.PL
47 %{__make} OPTIMIZE="%{rpmcflags}"
48
49 %{?_with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT{%{perl_sitelib}/DBIx,%{perl_sitearch}/auto/DBD}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README ToDo
64 %attr(755,root,root) %{_bindir}/*
65 %dir %{perl_sitelib}/DBIx
66 %{perl_sitearch}/DBI.pm
67 %dir %{perl_sitearch}/DBI
68 %{perl_sitearch}/DBI/Const
69 %{perl_sitearch}/DBI/[DFPS]*.pm
70 %{perl_sitearch}/DBD
71 %dir %{perl_sitearch}/auto/DBD
72 %dir %{perl_sitearch}/auto/DBI
73 %{perl_sitearch}/auto/DBI/*.h
74 %{perl_sitearch}/auto/DBI/Driver.xst
75 %{perl_sitearch}/auto/DBI/DBI.bs
76 %attr(755,root,root) %{perl_sitearch}/auto/DBI/DBI.so
77 %{_mandir}/man1/*
78 %{_mandir}/man3/D*
This page took 0.066024 seconds and 4 git commands to generate.