]> git.pld-linux.org Git - packages/perl-DBI.git/blob - perl-DBI.spec
14913d260b44b8936c108446256eb4670c8e9827
[packages/perl-DBI.git] / perl-DBI.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DBI
7 %define pnam    DBI
8 Summary:        DBI - Database independent interface for Perl
9 Summary(pl):    DBI - niezale¿ny interfejs baz danych dla perla
10 Name:           perl-DBI
11 Version:        1.32
12 Release:        1
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
16 Patch0:         perl-DBI-changes.patch
17 BuildRequires:  rpm-perlprov >= 3.0.3-16
18 BuildRequires:  perl >= 5.6.1
19 %if %{?_with_tests:1}%{!?_with_tests:0}
20 BuildRequires:  perl-PlRPC
21 BuildRequires:  perl-Storable
22 BuildRequires:  perl-Net-Daemon
23 %endif
24 Obsoletes:      perl-DBI-FAQ
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      'perl(DBD::<foo>)' 'perl(DBI::Format)' 'perl(DBI::PurePerl)'
28
29 %description
30 The DBI is a database access module for the Perl programming language.
31 It defines a set of methods, variables, and conventions that provide
32 a consistent database interface, independent of the actual database
33 being used.
34
35 %description -l pl
36 DBI jest modu³em dostêpu do baz danych dla Perla.  Definiuje grupê metod,
37 zmiennych i konwencji, zapewniaj±cych spójny interfejs do baz danych,
38 niezale¿ny od typu aktualnie u¿ywanej bazy.
39
40 %prep
41 %setup -q -n %{pnam}-%{version}
42 %patch0 -p0
43
44 %build
45 perl Makefile.PL
46 %{__make} OPTIMIZE="%{rpmcflags}"
47
48 %{?_with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT{%{perl_sitelib}/DBIx,%{perl_sitearch}/auto/DBD}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README ToDo
63 %attr(755,root,root) %{_bindir}/*
64 %dir %{perl_sitelib}/DBIx
65 %{perl_sitearch}/DBI.pm
66 %dir %{perl_sitearch}/DBI
67 %{perl_sitearch}/DBI/Const
68 %{perl_sitearch}/DBI/[DFPS]*.pm
69 %{perl_sitearch}/DBD
70 %dir %{perl_sitearch}/auto/DBD
71 %dir %{perl_sitearch}/auto/DBI
72 %{perl_sitearch}/auto/DBI/*.h
73 %{perl_sitearch}/auto/DBI/Driver.xst
74 %{perl_sitearch}/auto/DBI/DBI.bs
75 %attr(755,root,root) %{perl_sitearch}/auto/DBI/DBI.so
76 %{_mandir}/man1/*
77 %{_mandir}/man3/D*
This page took 0.084231 seconds and 3 git commands to generate.