]> git.pld-linux.org Git - packages/perl-DBD-Pg.git/blob - perl-DBD-Pg.spec
- "Tcl" and "Tk" unifications (and few others)
[packages/perl-DBD-Pg.git] / perl-DBD-Pg.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DBD
7 %define pnam    Pg
8 Summary:        A PostgresSQL interface for Perl
9 Summary(cs):    PostgresSQL rozhraní pro Perl
10 Summary(da):    Et PostgreSQL-grænseflade for Perl
11 Summary(de):    Ein PostgreSQL-Interface für Perl
12 Summary(es):    Interfaz PostgresSQL para Perl
13 Summary(fr):    Interface PostgresSQL pour Perl
14 Summary(it):    Interfaccia PostgreSQL per Perl
15 Summary(ja):    Perl ¤Î PostgreSQL ¥¤¥ó¥¿¡¼¥Õ¥§¥¤¥¹
16 Summary(ko):    ÆÞÀ» À§ÇÑ PostgresSQL ÀÎÅÍÆäÀ̽º
17 Summary(nb):    Et PostgreSQL-grensesnitt for Perl
18 Summary(pl):    Perlowy interfejs do PostgresSQL-a
19 Summary(pt):    Uma interface de Perl para o PostgresSQL
20 Summary(pt_BR): Uma interface de Perl para o PostgresSQL
21 Summary(ru):    éÎÔÅÒÆÅÊÓ PostgresSQL ÄÌÑ Perl
22 Summary(sv):    Ett gränssnitt till PostgresSQL för Perl
23 Summary(uk):    Perl-¦ÎÔÅÒÆÅÊÓ ÄÏ PostgresSQL
24 Summary(zh_CN): Perl µÄ PostgresSQL ½çÃæ¡£
25 Name:           perl-DBD-Pg
26 Version:        1.32
27 Release:        1
28 # same as perl
29 License:        GPL v1+ or Artistic
30 Group:          Development/Languages/Perl
31 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
32 # Source0-md5:  9d6a936e6f755af677ceef59272a50ac
33 BuildRequires:  perl-DBI
34 BuildRequires:  perl-devel >= 1:5.8.0
35 BuildRequires:  postgresql-devel
36 BuildRequires:  rpm-perlprov >= 4.1-13
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _noautoreq 'perl(POSIX(qw(isprint)))'
40
41 %description
42 DBD::Pg - PostgreSQL database driver for the DBI module.
43
44 %description -l cs
45 Implementace DBI pro PostgreSQL do Perlu.
46
47 %description -l da
48 Denne pakke indeholder en implementation af DBI for PostgreSQL for
49 Perl.
50
51 %description -l de
52 Dieses Paket enthält eine Implementierung von PostgreSQL für Perl.
53
54 %description -l es
55 Este paquete contiene una implementación de DBI para PotgreSQL para
56 PERL.
57
58 %description -l fr
59 Ce paquetage contient une mise en oeuvre de DBI pour PostgreSQL pour
60 Perl.
61
62 %description -l it
63 Questo pacchetto contiene un'implementazione di DBI per PostgreSQL per
64 Perl.
65
66 %description -l ja
67 ¤³¤Î¥Ñ¥Ã¥±¡¼¥¸¤Ë¤Ï Perl ¤Î PostgreSQL ÍÑ DBI ¼ÂÁõ¤¬¼ýÏ¿¤µ¤ì¤Æ¤¤¤Þ¤¹¡£
68
69 %description -l ko
70 ÀÌ ÆÐÅ°Áö´Â ÆÞÀ» À§ÇÑ PostgreSQLÀÇ DBI ½ÇÇöÀ» Æ÷ÇÔÇÏ°í ÀÖ½À´Ï´Ù.
71
72 %description -l nb
73 Denne pakken inneholder en implementasjon av DBI for PostgreSQL for
74 Perl.
75
76 %description -l pl
77 DBD::Pg - Sterownik bazy danych PostgreSQL dla modu³u DBI.
78
79 %description -l pt
80 Este pacote contém uma implementação de DBI para o PostgreSQL para o
81 Perl.
82
83 %description -l pt_BR
84 Este pacote contém uma implementação de DBI para o PostgreSQL para o
85 Perl.
86
87 %description -l ru
88 üÔÏ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ DBI ÄÌÑ PostgreSQL ÄÌÑ Perl.
89
90 %description -l sv
91 Detta paket innehåller en implementation av DBI för PostgreSQL för
92 Perl.
93
94 %description -l zh_CN
95 ¸ÃÈí¼þ°ü°üÀ¨ÓÃÓÚ Perl µÄ PostgreSQL µÄ DBI ÊµÏÖ¡£
96
97 %prep
98 %setup -q -n %{pdir}-%{pnam}-%{version}
99
100 %build
101 POSTGRES_LIB="%{_libdir}"; export POSTGRES_LIB
102 POSTGRES_INCLUDE="%{_includedir}/postgresql"; export POSTGRES_INCLUDE
103 %{__perl} Makefile.PL \
104         INSTALLDIRS=vendor
105 %{__make} \
106         OPTIMIZE="%{rpmcflags}"
107
108 %{?with_tests:%{__make} test}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc Changes README
122 %{perl_vendorarch}/DBD/*
123 %dir %{perl_vendorarch}/auto/DBD/Pg
124 %{perl_vendorarch}/auto/DBD/Pg/Pg.bs
125 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/Pg/Pg.so
126 %{_mandir}/man[13]/*
This page took 0.041581 seconds and 4 git commands to generate.