]> git.pld-linux.org Git - packages/perl-DBD-Pg.git/blob - perl-DBD-Pg.spec
- version 2.2.1
[packages/perl-DBD-Pg.git] / perl-DBD-Pg.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 %bcond_with     dbtests # perform tests using local PostgreSQL installation
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    DBD
8 %define         pnam    Pg
9 Summary:        A PostgresSQL interface for Perl
10 Summary(cs.UTF-8):      PostgresSQL rozhraní pro Perl
11 Summary(da.UTF-8):      Et PostgreSQL-grænseflade for Perl
12 Summary(de.UTF-8):      Ein PostgreSQL-Interface für Perl
13 Summary(es.UTF-8):      Interfaz PostgresSQL para Perl
14 Summary(fr.UTF-8):      Interface PostgresSQL pour Perl
15 Summary(it.UTF-8):      Interfaccia PostgreSQL per Perl
16 Summary(ja.UTF-8):      Perl の PostgreSQL インターフェイス
17 Summary(ko.UTF-8):      펄을 위한 PostgresSQL 인터페이스
18 Summary(nb.UTF-8):      Et PostgreSQL-grensesnitt for Perl
19 Summary(pl.UTF-8):      Perlowy interfejs do PostgresSQL-a
20 Summary(pt.UTF-8):      Uma interface de Perl para o PostgresSQL
21 Summary(pt_BR.UTF-8):   Uma interface de Perl para o PostgresSQL
22 Summary(ru.UTF-8):      Интерфейс PostgresSQL для Perl
23 Summary(sv.UTF-8):      Ett gränssnitt till PostgresSQL för Perl
24 Summary(uk.UTF-8):      Perl-інтерфейс до PostgresSQL
25 Summary(zh_CN.UTF-8):   Perl 的 PostgresSQL 界面。
26 Name:           perl-DBD-Pg
27 Version:        2.2.1
28 Release:        1
29 # same as perl
30 License:        GPL v1+ or Artistic
31 Group:          Development/Languages/Perl
32 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
33 # Source0-md5:  a988d2f80ed96c01b38550122284ba2c
34 URL:            http://search.cpan.org/dist/DBD-Pg/
35 BuildRequires:  perl-DBI
36 BuildRequires:  perl-devel >= 1:5.8.0
37 BuildRequires:  postgresql-devel
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _noautoreq 'perl(POSIX(qw(isprint)))'
42
43 %description
44 DBD::Pg - PostgreSQL database driver for the DBI module.
45
46 %description -l cs.UTF-8
47 Implementace DBI pro PostgreSQL do Perlu.
48
49 %description -l da.UTF-8
50 Denne pakke indeholder en implementation af DBI for PostgreSQL for
51 Perl.
52
53 %description -l de.UTF-8
54 Dieses Paket enthält eine Implementierung von PostgreSQL für Perl.
55
56 %description -l es.UTF-8
57 Este paquete contiene una implementación de DBI para PotgreSQL para
58 PERL.
59
60 %description -l fr.UTF-8
61 Ce paquetage contient une mise en oeuvre de DBI pour PostgreSQL pour
62 Perl.
63
64 %description -l it.UTF-8
65 Questo pacchetto contiene un'implementazione di DBI per PostgreSQL per
66 Perl.
67
68 %description -l ja.UTF-8
69 このパッケージには Perl の PostgreSQL 用 DBI 実装が収録されています。
70
71 %description -l ko.UTF-8
72 이 패키지는 펄을 위한 PostgreSQL의 DBI 실현을 포함하고 있습니다.
73
74 %description -l nb.UTF-8
75 Denne pakken inneholder en implementasjon av DBI for PostgreSQL for
76 Perl.
77
78 %description -l pl.UTF-8
79 DBD::Pg - Sterownik bazy danych PostgreSQL dla modułu DBI.
80
81 %description -l pt.UTF-8
82 Este pacote contém uma implementação de DBI para o PostgreSQL para o
83 Perl.
84
85 %description -l pt_BR.UTF-8
86 Este pacote contém uma implementação de DBI para o PostgreSQL para o
87 Perl.
88
89 %description -l ru.UTF-8
90 Это пакет содержит реализацию DBI для PostgreSQL для Perl.
91
92 %description -l sv.UTF-8
93 Detta paket innehåller en implementation av DBI för PostgreSQL för
94 Perl.
95
96 %description -l zh_CN.UTF-8
97 该软件包包括用于 Perl 的 PostgreSQL 的 DBI 实现。
98
99 %prep
100 %setup -q -n %{pdir}-%{pnam}-%{version}
101
102 %build
103 POSTGRES_LIB="%{_libdir}"; export POSTGRES_LIB
104 POSTGRES_INCLUDE="%{_includedir}/postgresql"; export POSTGRES_INCLUDE
105 %{__perl} Makefile.PL \
106         INSTALLDIRS=vendor
107 %{__make} \
108         CC="%{__cc}" \
109         OPTIMIZE="%{rpmcflags}"
110
111 # skip SIGNATURE test (uses network to get PGP key)
112 rm SIGNATURE
113 %{?with_tests:%{__make} test %{!?with_dbtests:DBI_DSN=NOWAY}}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc Changes README
127 %{perl_vendorarch}/DBD/Pg.pm
128 %dir %{perl_vendorarch}/auto/DBD/Pg
129 %{perl_vendorarch}/auto/DBD/Pg/Pg.bs
130 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/Pg/Pg.so
131 %{_mandir}/man3/DBD::Pg.3pm*
This page took 0.100231 seconds and 4 git commands to generate.